Dev Environment Setup

In order to develop the LiteracyBridge software projects you need to setup your development environment and download the source code.
Here is a step-by-step guide that helps with the setup:

Download and configure Eclipse

  1. Download Eclipse IDE for Java Developers from [http://www.eclipse.org/downloads/packages/release/indigo/sr2] (The current eclipse version "Juno" does not provide a working subversion connector for m2e. Use Eclipse "Indigo".)
  2. Install the following plugins by using the Help -> Eclipse Marketplace… function
      • Subversive – SVN Team Provider (After the restart of Eclipse, select “SVN Kit 1.3.7” and “JavaHL 1.6.x” in the “Install Connectors” dialog)
      • m2e-subversive (In Eclipse, click File -> New -> Other… and select Maven -> Checkout Maven Projects from SCM. On the “Checkout as Maven project from SCM” dialog, click on the link at the bottom to “Find more SCM connectors in the m2e Marketplace”. Install the “m2e-subversive” connector).

Download the source code

  1. In Eclipse, click File -> New -> Other…
  2. Select Maven -> Checkout Maven Projects from SCM and click Next
  3. Select svn in the dropdown list and enter Literacy Bridge's subversion url:
  4. Make sure Check out Head Revision and Check out All projects are both checked
  5. Click Finish

Eclipse now downloads all source code, fetches dependencies using Maven, and creates a separate project for each software module.

Building and starting the ACM project

After making changes in acm-core it is necessary to invoke the Maven build, which compiles and deploys the backend jar file in the UI's lib directory:

  1. Right-click on acm in the Package Explorer in Eclipse
  2. Click Run As -> Maven Install
  3. After the build completed expand the acm-gui project in the Package Explorer
  4. Navigate into the java package: org.literacybridge.acm.ui
  5. Right-click on Application.java and click Run As -> Java Application